Testarea compatibilitatii pluginurilor WordPress

Inca din mai 2003, cand binecunoscuta platforma de tip publishing WordPress a facut primii pasi in lumea open source, o serie de programatori talentati si fanatici au incercat sa ofere micului script mai multa culoare, prin dezvoltarea unor aplicatii pe care acum le numim plugins.

S-au lansat zeci de mii de plugins-uri, unele dintre acestea care ajuta la obtinerea unei vizibilitati sporite in ochii lui Google, altele care completeaza pagina cu elemente grafice si utile vizitatorilor, dar toate isi propun un singur lucru: sa ofere mai mult!

Pana aici toate bune si frumoase! Fiecare webmaster iubitor de solutii web simple si ieftine foloseste acum WordPress, dar problema cu care se poate confrunta consta in incompatibilitatea versiunii WordPress cu pluginul dorit. De altfel, un motiv pentru care foarte multi dintre dvs nu doriti sa upgradati actuala varianta de WordPress ar fi eventualele probleme, sau altfel spus, incompatibilitatile cu plugins-urile de care nu va puteti lipsi. Multi dintre dvs va ganditi ca este mai bine sa ramaneti vulnerabil in fata atacurilor, decat sa va lipsiti de plugins-urile care sunt esentiale in activitatatea desfasurata. Ei bine, ganditi gresit!

Atat updatarea scriptului de wordpress, cat si plugins-urile dvs sunt absolut necesare, iar o solutie pentru a scapa de frica esecului se numeste “Better Plugin Compatibility Control”.

Ce face pluginul “Better Plugin Compatibility Control” ?

Are rolul de a va informa, in sectiunea plugins a panoului de control, care plugins-uri sunt ok din punct de vedere tehnic si le puteti rula, si care dintre pluginsuri ar fi bine sa fie evitate, pentru ca nu sunt compatibile variantei de WordPress folosita. Un screenshot sugestiv despre cum va informeaza acest plugin despre eventualele incompatibilitati poate fi vizitat la adresa http://wordpress.org/extend/plugins/better-plugin-compatibility-control/. De altfel, puteti accesa link-ul daca doriti sa descarcati aplicatia si sa cititi instructiunile de instalare al acesteia.

O a doua solutie prin care puteti verifica daca noua varianta de WordPress lansata este compatibila cu actualele plugins-uri, fara de care nu puteti jongla in exorbitantul spatiu internautic, ar fi verificarea manuala a acestora, direct pe site-ul oficial WordPress. Comparativ cu prima varianta, care presupune instalarea efectiva a unui plugin, aceasta poate “manca” mai mult timp, insa va scapa de spatiu si resurse consumate inutil.

Cum verificati pe site-ul oficial daca un plugin este compatibil cu viitoarea varianta de WordPress?

Primul lucru pe care trebuie sa-l faceti este sa preluati complet numele pluginului despre care doriti informatia si sa-l copiati in formularul “search” al paginii plugins de pe siteul oficial WordPress. Este esential ca numele pluginului sa fie copiat in totalitate, pentru a-l gasi pe prima pozitie. Odata accesata pagina pluginului, puteti arunca o privire la sectiunea “Compatibility”, in dreapta paginii. De altfel, tot la sectiunea “Compatibility” aveti posibilitatea de a proba compatibilitatea unei versiuni mai vechi de plugin cu o varianta de wordpress dorita, rezultatul fiind obtinut prin colectarea de feedbackuri pozitive sau negative din partea utilizatorilor.

Aceste doua solutii va pot asigura ca toate plugins-urile pe care le folositi sunt ok si “ready” pentru noua varianta de WordPress care asteapta sa va serveasca fie magazinul virtual, fie site-ul de prezentare, fie blogul personal!

Lasa un mesaj